Problem

When you attempt to download email using POP/POP3, the following error can occur:

"Your mailbox is already locked"

Symptom

  1. Your email client will not download email and displays the error message above.
  2. The problem is intermittent.
  3. You are using POP/POP3 to download email.
  4. The problem occurs with different users, from different domains.
  5. You are able to download email using IMAP and Webmail.

Cause

Your mailbox has been automatically locked.

Resolution

Locked mailboxes are automatically unlocked after 2-5 minutes of inactivity.

Only one user at a time can use a POP mailbox (the same mailbox). If another user, attempts to connect to the same mailbox at the same time, they will get a lock notification.

If you are sharing your DomainsFoundry mailbox across multiple devices consider using IMAP.